魔兽争霸3需要特定语言版本之windows的解决办法

英文版的XP/2003/VISTA/2008/7.0等系统下玩中文版魔兽争霸/冰封王座的方法运行程序后,弹出一个对话框:“此版本之Warcraft3需要特定语言版本之windows ”;点“确定”后,又弹出一个对话框,提示光盘检测错误请插入光盘。看来,中文版的魔兽争霸在英文版的系统下运行有问题。于是用 UltraEdit 打开了魔兽争霸安装目录下的“game.dll”文件,查找到16进制串”3D04080000742A3D04″,将其中的74改为EB,保存,之后再次运行魔兽争霸程序,呵呵,一切正常,没有任何问题了。

2009年9月1日 补充:
以上方法适用于魔兽1.20、1.21版本。
如果您用的是1.22的版本,则搜索的内容是”
3D04080000741B3D0410000074143D040C0000740D“, 然后把第一处的74改成EB。

新增方法二(适用与包括1.23+的魔兽各个版本,建议先尝试这个方法 ;-) ):

1.开始-运行-输入regedit

2.找HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001 \Control\Nls\Language\ 路径,在右边找InstallLanguage,把数值改成0804(英文版的应该是0409)。
【本行所写,如果你的系统没有,可以省略。】然后在找到一个叫default的0409 (英文版的应该是0804),InstallLanguage 和default 分别是0804 和 0409 的其中一个,按F5.

3.重启windows(PS:一定要重启的哦,不然不能玩的.还有一个问题,把这个改了以后会使windows的文件搜索不能使用,要用那个的话,改回来.重启就可以了,反正一般也不会怎么用的咯).

2010年9月6日 更新:
由于魔兽1.24+以上的版本以上方法不适用,我已经更新了方法,请访问这里

关于浪漫谎言

浪漫谎言,ALLCAN工作室创始人,从事网站开发、网站美工、网络编程等。
此条目发表在软件·电脑相关分类目录,贴了, , , , , 标签。将固定链接加入收藏夹。

魔兽争霸3需要特定语言版本之windows的解决办法》有 3 条评论

  1. Ari说:

    我改了那个数据,结果电脑打不开了 安全模式下系统还原。

  2. wangwang说:

    修改成功!大大的方法很不错!谢谢!

  3. Pingback引用通告: 魔兽争霸3(1.24+)需要特定语言版本之windows的解决办法 | 浪漫谎言の网络记事本

发表评论

电子邮件地址不会被公开。 必填项已用*标注

您可以使用这些HTML标签和属性: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>